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Library Component Creation 

 

Basic Terminologies 

Grid: Graphical aid for placing the component 

Snap: The minimum distance that the cursor can jump from one position to another 

position with an object tagged to it. 

Angular Snap: The minimum angle that the cursor can jump with an object tagged to it 

Entry Point: The point at which the electrical connection given or taken to/from the 

component pin. 

Pad: A circular/ oval/ rectangular/ line shaped seat for component pin with necessary 

diameter and hole (optional) created with copper. 

 

Units 

1"=1000mils 

1"=25.4mm 

0.1"=2.54mm=100mils 

From View choose Units  inches 

Set Grid as 0.1" and Snap as 0.05" 

 

Naming Conventions 

 

Packages in EDWinXP are named in the format Package type No: of pins in the 

package/horizontal pitch between the pad in mils. Eg: DIP14/300 where DIP is the 

package type, 14is the no: of pins in the package and 300 is the horizontal pitch between 

the pads in mils. 

 

To create a library part first you need to create the symbol and package of the part. Part 

constitutes of Symbol and package. 
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Library creation Using Wizard 

 

Open EDWinXP Main from Start ProgramsEDWinXP EDWinXP Main. Choose Library 

right click Library and choose Library Editor. 

 

Creation of Symbol 

For creating symbols automatically, select Symbol tab / File/New Symbol using Wizard 

from Library Editor. This utility provides an easier interface for creating symbols. The 

Symbol creation wizard is as shown in figure below.  

1. Specify the name and type of the symbol. For eg : Specify the symbol name as 7408 

and symbol type as general symbol. Click on Next button to move to the parameter 

specification window. 

    

 
 

 

2. Specify the parameters, the description about the parameters that is to be specified 

while creating the symbol for 7408 is given below. Click on Next button, a new 

window appears which specifies the orientation of all entries, whether or not they are 

invertible, invisible etc. 
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No: of Entries (n)      :3 

Entry placement grid (P)    :.1000’’ 

No: of Pitch for terminal line length (nP)  :2 

Orientation of entries     : Auto 

Positions 

Component name     : Top 

Component description    : Top 

Line Size      : .0020’’ 

Symbol Type     : Double click on the field, Select 

DigitalGate AND from the drop down menu.                                                               

Symbol Description    : AND Gate 

Check display entry names as text check box. 

 

 

 

3. In the new window edit, the entry name attributes. You can also indicate the swap 

level and Sim Name. An import pinlist option is also available. 
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The Pin details format should be like Pin-Number, Pin-Name, Pin-Orientation (valid Pin-

Orientations are *Left ( L ), Right (R),Bottom (B),Top (T). Any invalid format will produce 

error in operation. Comments should start with a '*' character. 

 

 

 

Window after importing the list is as shown below. 
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4. Click on Next button moves to a new window where the pitch between two entry pins 

can be specified.  
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For example if the pitch between the pins has to be changed to 4 then give 1, 2, 4 in the 

field allowed for entering and click on the up arrow and then click on the arrow directed to 

right. Then the pitch between the pins is changed as applied. 

 

Click on Next button moves to a new window, which displays the summary of information 

about the symbol created using the wizard. 

 

 

 

5. Click Finish to complete the process. 

From the File Menu choose Save Symbol As. In the new Window Set the Symbol 

Name and the Lib Name. 

Check On top of search sequence check box and Save. 
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Creation of Package 

In order to create package, click on Package tab.  

 

1. Select New Package using Wizard from the file menu for creating the package for 

example IC7408. 

2. Set the Package Name as DIP 14/300, 14 denote number of pins in this package 

and 300 denotes the width of the package. Package Type as Dual In Line 

Package (DIP).  
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3. Click Next button to continue.  
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In the Window, which appears, enter the following values 

No. of pins      : 14 

Pin to pin Distance   : 1000” 

Horizontal pitch between pads  : .3000” 

Length of Package outline  : .7000” 

Width Package outline   :. 2000” 

Package Description   :AND GATE 

 

4. Padstack is selected by double clicking on the field Default Padstack, a window for 

selecting padstack is displayed as shown in figure below. From the menu select the 

padstack and click Accept Selection. Then automatically the padstack name is 

assigned to the required field. 

 

 

 

5. Package Type is given by double clicking on this field, a window for selecting the 

package type is displayed. From the drop down menu select PMD DIP  DIP 

Narrow. Click Accept. 
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6. Click Next, Change the Pad Name of first pad (#1) to P_SQR_55_H_30. 

 

 

 

7. Click Next. 
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8. Click Next. 

 

9.  Click Finish. 

10. From the File Menu choose Save Package As. 
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11. Give Package name as DIP14/300 and Lib Name as Sample 

12. Check On top of search sequence check box and Save. 

 

Creation of Part 

1. Click on Part Edit tab, enter the Part and Package details as 

          Part details 

Name   : 7408 

Description  : AND Gate 

Select manufacturer, technology and type from the drop down menu by double clicking 

on the required field. 

Manufacturer   : Fairchild 

Technology   : TTL 

      Type   : DigitalGate AND 

           Package Details 

Package    : DIP14/300 

 Click Yes for the question “Are you sure to change the package?” 

 Select Package type by double clicking on the field and select PMD DIP DIP Narrow. 
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2. From the Edit Menu choose Add Group, In the new window, Give 1, 7408 (Symbol 

name given during creating symbol). Similarly add 3 more groups by repeating Edit 

Add Group.  

 

 

 

3. After adding four groups, Choose Edit Edit Pinout. Inorder to view assigning each 

group to the package select Edit Show Package Window. 

 

4. Choose Edit First group and assign first group to the package by clicking on the 

Entry field. Select inputs and output pins according to the package.  

 

5. Select Edit Next Group to assign the second group to the package. Name Pin no: 

7 as SPL0 and Pin No: 14 as SPL1. Assign groups third and fourth similarly as done 

early. 
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6. Select File  Save Part, give Part Name as AND and Lib Name as Sample.  

7. Check On top of search Sequence check box and Click Save. 
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Creation of Padstack 

 

1. Select File | New Padstack using Wizard. to pop up window as shown in figure 
below. 

 

 

 

2. In the window, a miniature representation of the padstack is shown in the preview.  

Right click on the preview for options to view True size, Hrf items and Airgap view. 

From the Fetch from Padstack Library(s) tab, select the padstack 

“N_RND_100_H_100”. Now on moving to the Edit or create new padstack tab, the 

padstack details of “N_RND_100_H_100” appears.  

 

3. The minimum information required to create a New Padstack is given in the figure 

below. The user may edit the values.  

 

Name = N_RND_100_H_100 and press the <enter> key. 

Create HRF items = select the checkbox 

Airgap = 0.0120" 

Hole Category = 0 

Hole diameter = 0.1000" 
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4. On clicking the Edit by layers button, the pad details of different layers (Shape, 

diameter, Airgap and the option of selecting the layers to be used) appears.  

 

 Global Editing of layers is also allowed.  
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5. Finally click the button Make to create the new padstack. Now the edited changes are 

visible in the Preview in the right pane. Click on Proceed to manual editing to effect 

the changes and exit. 

This completes the Padstack creation using wizard. The edited padstack appears in 

the Padstack editor and further edition can be done using the tools available.  

 

Library Creation without using Wizard 

 

Open EDWinXP Main from Start ProgramsEDWinXP EDWinXP Main 

Choose Library, right click Library and choose Library Editor. 

 

Creation of Symbol 

 

1. From Library Editor choose Symbol tab at the bottom of the page.  

2. To create a symbol of OR gate, select the  Set Contact Point (function tool) 

select the first option tool  and place it on the grid. Similarly select the second 

one  and place it on the next grid as shown. 

 

 

 

3. Select the  Create graphic item (function tool)   Create arc (option tool). Click 

anywhere near the contact point to get an arc tagged to the cursor.  
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4. After adjusting the size of the arc, click to place it. Adjust the arc, if necessary, by 

selecting the    Stretch Item function tool and click the  Stretch arc radius tool 

or press F1 key, to change the radius of the arc.  

5. Repeat the arc as needed, after placing the arc press ESC.  

6. Select  Create line and click on the workspace where the line needed.  

 

 

 

 

 

7. Repeat the same line using the tool  Repeat Graphic Item, select this tool and 

click on the workspace then a line is tagged with the cursor, place it where required. 
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8. Place the first/default entry (+) present in the workspace, exactly at the starting 

point of the first pin of the OR gate using the  Relocate item tool.  

9. Select the  Create graphic item tool and click the  Create entry pin option tool 

or press F6 key, for creating the remaining entry points. Click on the starting point 

of the pins. 

 

 

 

10. From the File Menu choose Save Symbol As 

11. In the new Window. 

Set the Symbol Name and the Lib Name 

Check On top of search sequence check box and Save. 
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Creation of Package 

 

From Library Editor choose Package tab at the bottom of the page.  

Select the Component Print, by default component layer will be selected. 

To create the outline of the package, select Create Graphic Item (Function tool) Create 

rectangle (Option tool). 

Place the first/ default pad (+) exactly at the place of the first pad using the  Relocate 

item tool.  

 

 

For placing the remaining second pad select the  Create graphic item tool and click the 

Create Pad option tool. 
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The pad is placed at the required position and displayed as a small “x”. To change the 

padstack, click  Change Padstack tool and select  Select Padstack option tool. 

 

 

 

Select an SMD pad, Eg: Select S_RCT_40*48 SMD pad.  

Click Edit or create new padstack tab Edit by layers tab to edit the shape and size of 

the pad.  

To reflect the changes made in the selected padstack click  button.  

Click the Accept Select button to select this padstack. Click on the center of each pad to 

locate the pads made.  

 

From the File Menu choose Save Package As. 

Give Package name as OR Gate and Lib Name as Sample.  
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Check On top of search sequence check box and Save. 

 

Creation of Part 

Same as in the creation of part using wizard. 

 

 


