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Module Settings 

 

The topics covers briefly the necessary settings required to be done in individual modules. 

 

• General Settings  

• Schematic Editor Settings  

• Mixed Mode Simulator Settings  

• EDSpice Simulator Settings  

• Layout Editor Settings  

• Thermal Analyzer Settings  

• Electromagnetic Analyzer Settings  

• Fabrication Manager Settings  

• Symbol Editor Settings  

• Library Browser/ Library Explorer Settings  
 

General Settings 

 

Most of the general settings common to almost all the editors of EDWinXP are set from the 

Options Setup window.  

i. Open EDWinXP project explorer  
ii. Right click System Options. 

 

Steps for undo/redo 
 

Select Options Setup  General  Recovery & Units .The Undo/ Redo level may be set to 

vary from 1 to 10 for all the editors except Library Editor, where it can vary from 1 to 30. As the 

number of level increases, the system may slow down and hence the user is provided with an 

option to set it as per his need. The user can also switch On or Off the Undo/ Redo feature from 

all the editors. Now to effect this change as the default setting, select the “Save & Exit” from the 

  dropdown button before exiting from this window. 

Note: If this change is just for the current project, then click the Apply button and exit. 
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Angle Snap 
 

The Angle snap determines the steps for angular rotation of a component, component name, 

notes etc while relocating an item. The angle snap set from the options window will be the default 

angle snap for all the editors. The angle snap may be changed afterwards from each of the 

editors individually as per the requirement.  

i. Select Sizes  General  Angle Snap from the Options Setup window.  
ii. Now to effect this change as the default setting, select the “Save & Exit” from the 

dropdown button before exiting from this window. 

Note: If this change is just for the current project, then click the Apply button and exit. 

 

Grid Setting 
 

Grid helps to align the components well. The grid value set from the options window will be the 

default grid value for all the editors. The grid value may be changed afterwards from each of the 

editors individually as per the requirement. 

Now to effect this change as the default setting, select the “Save & Exit” from the    

dropdown button before exiting from this window. 

Note: If this change is just for the current project, then click the Apply button and exit. 

 

Symbol Line Width 
 

The symbol line width of the symbols in the schematic diagram may be changed from the Project 
Properties window. The project properties window is invoked from the project explorer. Right 

click on the task Project and select Project Properties. The Project Properties window opens 

up. Select the Advanced tab. The symbol line width may be set as required in terms of 

dimension or percentage. Note that this setting is only for the current schematic diagram. In order 

to change the symbol’s line width permanently, it must be edited from the Symbol editor. 

 

Unit Setting 
 

The Unit setting in the options window will apply to all the editors. The unit may be changed from 

each of the editors as per the users need but there is a possibility to override the unit setting of 

individual editors.  
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To override the unit settings, from the options window, Select General  Recovery & Units. 

Check the option Override Editors with System Units. Now to effect this change as the default 

setting, Select the “Save & Exit” from  dropdown button before exiting from this 

window. 

Note: If this change is just for the current project, then click the Apply button and exit. 
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Schematic Editor Settings 

 
Thickness of Wires/Buses 
 

The thickness of wires/buses in the schematic diagram may be changed from the Project 

properties window. The project properties window is invoked from the project explorer. Right click 

on the task Project and select Project Properties. The project properties window opens up. Select 

the Advanced tab. The wire/bus width may be set as required in terms of dimension or 

percentage. Note that this setting is only for the current schematic diagram.  

i. In order to change the default wire width, it must be set from the options window. The 

Options setup window is invoked from the project explorer. Right click on the task 

System and select Options. 

ii. From the options setup window, select Sizes  Schematic  Bus  Wire Width. 
Set the value as required. Now to effect this change as the default setting, select the 

“Save & Exit” from the    dropdown button before exiting from this 

window. 

Note: If this change is just for the current project, then click the Apply button and exit. 

 

Page Size (Default) 
 

The default page size is set from the options window.  

i. The Options setup window is invoked from the project explorer.  

ii. Right click on the task System and select Options. Select Format  Schematic 
Page.  

iii. Select the required size.  

iv. Now to effect this change as the default setting, select the “Save & Exit” from the 

  dropdown button before exiting from this window. 

Note: If this change is just for the current project, then click the Apply button and exit. 

 

Setting colors in Schematic Editor. 
 

The color of almost all the items present in the schematic diagram may be changed from the 

options window and can be set as the default color.  
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i. Right click on the task System and select Options.  

ii. Select Color & Layer Schematic.  

iii. Set the color by picking the required color from the color palette and filling it against 

the required items listed.  

iv. Now to effect this change as the default setting, select the “Save & Exit” from the  

 dropdown button before exiting from this window. 

Note: If this change is just for the current project, then click the Apply button and exit. 

 

 

Packaging details of components 
The packaging details may be manipulated as per the user need.  

i. Open EDWinXP project explorer and select System  Options  Packaging 
Pref.  

ii. The component name, pinout details and the component description may be 

switched On/ Off. The font and size of these texts may be selected.  

iii. Now to effect this change as the default setting, select the “Save & Exit” from the 

    dropdown button before exiting from this window. 

Note: If this change is just for the current project, then click the Apply button and exit. 

 

Labeling scheme 
 

Labels are attached to symbols when placed on to the schematic. The font and size of the labels 

may be set as required.  

Open EDWinXP project explorer and select System  Options  Comp. Label Scheme  
Schematic and edit the settings as required. Now to effect this change as the default setting, 

select the “Save & Exit” from the  dropdown button before exiting from this 

window. 

Note: If this change is just for the current project, then click the Apply button and exit. 

 

 

Setting component values 
 

The component values may be set either from the schematic editor module or from the mixed 

mode simulator itself. The values of certain components such as resistors, capacitors, etc may be 

set from the schematic editor.  
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Select the option tool Add/Change Component values (function tool) Add /Change 
Component Text and click on the component. An input box opens up where the component 

values separated using commas may be entered. The input voltages for generators etc. are set in 

a similar fashion from either the schematic editor or from mixed mode simulator. 

 

Predefined Net Name 
Enable the option ‘Instant Net Name’ from the Preference menu. On commencing wire routing 

from a point, an input box pops up where the net name might be entered.  

 
Predefined Wire Label 
Enable the option ‘Instant Wire Label’ from the Preference menu. Once the routing is over, the 

wire label (which is actually the net name) gets tagged to the cursor and may be placed at 

appropriate location. 
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Mixed Mode Simulator Settings 

 

Set the component values 
 

The component values may be set either from the schematic editor module or from the mixed 

mode simulator itself. The component values are set using the option tool, Set Parameter, of the 

first function tool of mixed mode simulator. Select the tool and click on the component. The 

parameters of the selected component may be edited in the window that opens up. The 

parameters may be borrowed from the available SPICE parameters or the parameters available 

from mixed mode parameter library. 

The values of certain components such as resistors, capacitors, etc may be set from the 

schematic editor itself. Select Add/Change Component values (option tool)   Add/Change 
Component Text and click on the component. An input box opens up where the component 

values separated using commas may be entered. 

The input voltages for generators etc. are set in a similar fashion from either the schematic editor 

or from mixed mode simulator. 

 

Setting the Ground 
 

The GND may be set in two ways. From the schematic editor, load the GND symbol and place it 

appropriately in the circuit and complete the connections. Or else from the mixed mode simulator 

module, place the GND reference marker at appropriate point in the circuit using the function tool 

Set Ground.  

 

Simulation Function 
 

Select Assign Simulation Model (option tool )  Set Parameters | Models (function tool). Click 

on the symbol to open a window. Click the button Assign Simulation Function to assign the 

simulation function as required. 

To change the simulation function of the symbol permanently, open the symbol in the symbol 

editor for editing. Select the symbol for editing in the Symbol Editor. Select the option tool 

Symbol Properties from the function tool Properties. In the window that opens up, select the 

simulation function as required. 
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EDSpice Simulator Settings 

 

Setting the values for different components 
 

The component values may be set either from the schematic editor module or from EDSpice 

simulator itself. The component values are set using the function tool, Set Parameters | models 

of EDSpice simulator. Select the tool and click on the component. The instance parameters of the 

selected component may be edited in the window that opens up. 

The values of certain components such as resistors, capacitors, etc may be set from the 

schematic editor itself. Select Add | Change Component values (option tool) Add/ Change 
Component Text (function tool) and click on the component. An input box opens up where the 

component values separated using commas may be entered. 

The input voltages for generators etc. are set in a similar fashion from either the schematic editor 

or from EDSpice simulator. 
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Layout Editor Settings 

 

Via Size 
 

Seven types of Vias are available in EDWinXP. Each of the via has different size and the size 

may be changed as per the user need. To change the size of via, Select Tools  Via Padstack 

from the menu of the layout editor. A window “Edit Via Padstack” opens up where all the 

properties of the via such as size, shape, air gap, etc. may be edited. The setting remains until 

EDWinXP is closed.  

 

Airgap Size 
 

From the options setup window, Select Sizes  Layout  Airgap Size. The airgap size set 

from the options window will be the default Airgap Size for all the editors. The airgap size may be 

changed afterwards from Layout Editor or Fabrication Manager individually as per the 

requirement. Now to effect this change as the default setting, select the “Save & Exit” from the 

  dropdown button before exiting from this window. 

Note: If this change is just for the current project, then click the Apply button and exit. 

 

 

Board Size (Default) 
 

The default board size is set from the options window.  

i. The Options setup window is invoked from the project explorer.  
ii. Right click on the task System and select Options. Select Format  Layout board.  
iii. Select the required size.  

iv. Now to effect this change as the default setting, select the “Save & Exit” from the 

   dropdown button before exiting from this window. 

Note: If this change is just for the current project, then click the Apply button and exit. 
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Change the color of the various layout items such as background, board outline, etc. 
 

The color of almost all the items present on the board may be changed from the options window 

and can be set as the default color.  

i. Right click on the task System and select Options.  

ii. Select Color & Layer  Layout.  
iii. Set the color by picking the required color from the color palette and filling it against 

the required items listed.  

iv. Now to effect this change as the default setting, select the “Save & Exit” from the 

    dropdown button before exiting from this window. 

Note: If this change is just for the current project, then click the Apply button and exit. 

 

Change the color/ name of the layers. 
 

The color and name of all the layers in the layout may be changed from the options window and 

can be set as the default color and name for the layer.  

 

i. Right click on the task System and select Options.  

ii. Select Color & Layer  Layers.  

iii. Set the color by picking the required color from the color palette and filling it against 

the layers listed.  

iv. Appropriate color may be assigned to the category by keeping the Shift key pressed 

and click on the colors in the palette. This will randomly change the color of the 

category to the color selected. To know the right color the category is assigned, press 

CTRL and click on the category. This will highlight the color used in the color palette. 

The layer name may be edited directly in the edit box.  

v. Now to effect this change as the default setting, select the “Save & Exit” from the 

  dropdown button before exiting from this window. 

Note: If this change is just for the current project, then click the Apply button and exit. 

 

Labeling scheme 
 

The font and size of the prefix attached to the symbol when placed on the board may be set as 

required.  
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i. Open EDWinXP project explorer and select System  Options  Comp. Label 
Scheme  Layout and edit the settings as required.  

ii. Now to effect this change as the default setting, select the “Save & Exit” from the 

  dropdown button before exiting from this window. 

Note: If this change is just for the current project, then click the APPLY button and exit. 

 

User Defined Lay Prefix 
 

The prefix for the component to be loaded on the board may be set as per the user need.  

On enabling the option Preference  User Defined Lay.Prefix, an input box pops up where the 

prefix may be entered. The components loaded here after will have this pre-defined prefix. 

 

Note: All the settings given below are set in Default Design Rules Setup window, which is 

invoked, from EDWin Project Explorer. These settings may be set as default, for the current 

Project, or for the current Circuit. Most of the options set may or may not be used while preparing 

the design. To use these settings certain options may be set within the Layout Editor or 

corresponding modules. 

 

Routing Layers & Direction 
The layers and directing of the traces to be used may be set in Default Design Rules Setup 

window. 

 

Via Rules 
The type of Vias to be used and the number of vias may be specified in the Default Design 
Rules Setup window. 

 

Trace Rules 
The minimal and maximal trace parameters like width, airgap etc. may be set different using 

Default Design Rules Setup window. 

 

Clearances 
The clearance value i.e. the Pad to Pad distance, Trace to Pad distance, Trace to Trace distance 

and the Signal Trace Check Width may be specified here. 
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Autorouter 
Autorouter settings parameters may be specified in this Default Design Rules setup window. 

 

Locked Edit 
This option is particularly used at the final stage of the design to prohibit further edition to the 

design, ie. Certain operations may be locked using this option. 

 

Layout Component Placement 
Certain Design rules related to components may be set in the Design Rules Setup window. A 

special option i.e. Component snap may be specified in this window. When specified, this value is 

used by the layout editor but this value set can be surpassed by Ctrl key.  

How to use an alternate Snap value (for Layout Components only) using design rule setup dialog: 

Open Design Rule dialog from EDWin Project Explorer and enter the snap value say .1000” in 

Layout component Placement. In Layout Editor, set the snap value to .0500”. Now try relocating 

the components, you may find that the components move with Snap value .1000”. To use the 

Snap value selected in Layout editor, press CTRL key and try to relocate. Now the Layout 

Components move with Snap value .0500”. 
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Electromagnetic Analyzer Settings 

 

Settings required to conduct the analysis. 
 

The settings required to conduct the analysis can be set 

i. EDWinXP Project Explorer PCB Layout  
ii. Select Board Analyzer (task list)  Analysis (menu)  Settings. 
iii. Set the parameters related to the board, field values and the display options.  

iv. In addition to that, the electrical parameters, net parameters and trace 

parameters may be edited before the analysis, using the function tools provided.  

v. Select Analysis  Run Electromagnetic Analysis from the menu to run the 

analysis. 

 

 

Thermal Analyzer Settings 

 

Settings required to conduct the analysis. 
 

i. The settings required to conduct the analysis is set from the menu Analysis  
Settings. 

ii. Set the parameters related to the board, cooling parameters, temperatures and 

the display options.  

iii. In addition to that, each of the component parameters may be edited before the 

analysis, using the Component Parameters (function tool).  
iv. Select this tool and click on the required component to open a window where the 

parameters may be edited.  

v. Select Analysis  Run Thermal Analysis from the menu to run the analysis. 
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Fabrication Manager Settings 

 

Set net for the copper pour area. 
 

i. Once the editing mode is set as Tools(menu)  Copper,  the tool to select the 

net for the copper gets enabled.  

ii. Select View | Toolbars | Sizes from the menu to obtain the tool, Select Net.  

iii. Select the required net, from the drop down list containing all the net names 

iv. Now enable the tool for defining the copper pour area from the toolbar. 

 

Change the color/ name of print layers. 
 

The color and name of the print layers may be changed from the options window and can be set 

as the default color and name for the layer. Right click on the task System and select Options. 

Select Color & Layers | Layers. Set the color by picking the required color from the color palette 

and filling it against the layers listed. Appropriate color may be assigned to the category by 

keeping the SHIFT key pressed and click on the colors in the palette. This will randomly change 

the color of the category to the color selected. To know the right color the category is assigned, 

press CTRL and click on the category. This will highlight the color used in the color palette. The 

layer name may be edited directly in the edit box. Now to effect this change as the default setting, 

select the “Save & Exit” from the   dropdown button before exiting from this 

window. 

 

Note: If this change is just for the current project, then click the APPLY button and exit. 

 

 

Generate Gerber Data 
 

i. Open Fabrication Manager.  
ii. Select Fabrication-> Setup-> Gerber Plotter Data-> Gerber Artworks.  
iii. Select the layers for which the Gerber data is to be generated.  

iv. Click the Execute button.  

v. You may notice that the gerber files are generated for each layer with an 

extension .GBR file. Click the Execute button and close the window.  

 



Module Setting  Visionics 

 18

 

 

vi. Select File-> Gerber Viewer Setup to open a window.  

vii. Select the gerber file from ‘Gerber ASCII File’ and click the Preprocess 

button to preprocess the file.  

viii. To view, Select Tools-> Gerber View.  
 

 
Generate NC Drill Data 
 

i. Open Fabrication Manager. 
ii. Select Fabrication-> Setup-> NC-Drill Data-> Output Contents. 
iii. Click the Execute button to open a window.  

iv. Check the options to generate the drill database.  

v. Click Execute button and close the window.  

vi. Select Tools-> Template (Notes/Dim) for viewing. 

 

 

Generate PCB Assembly outputs 
 

i. Open Fabrication Manager.  
ii. Select Fabrication-> Setup-> PCB Assembly Outputs.  

iii. Select either Generic or IPC-D-355 format data output. 

 

 

Bare Board Testing outputs 
 

i. Open Fabrication Manager. 
ii. Select Fabrication-> Setup-> Bare Board Test Outputs.  
iii. Select either Generic or IPC-D-356A format data output. 
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Symbol Editor Settings 

 
Symbol Line Width 
 

The symbol line width of the symbols in the schematic diagram may be changed from the Project 

properties window.  

i. Invoke Project Properties from Project Explorer.  

Or 

Right click on the task Project and select Project Properties.  
ii. The project properties window opens up. Select the  Advanced tab. The 

symbol line width may be set as required in terms of dimension or 

percentage. Note that this setting is only for the current schematic diagram. 

In order to change the symbol’s line width permanently, it must be edited 

from the Symbol editor.  

iii. Select the symbol for editing in the Symbol Editor.  

iv. Select the Item Properties (option tool) from the Properties (function tool).  

v. Select Edit  Select All from the menu.  

vi. Right click on the workspace to obtain a pop up menu.  

vii. Select Properties  Symbol Items and change the line width in the 

properties window. 

viii. Save the symbol and the part to the user created library.  

 

Simulation Function 
 

In order to change the symbol’s simulation function permanently, select the symbol for editing in 

the Symbol Editor. Select the option tool Symbol Properties from the function tool Properties. In 

the window that opens up, select the simulation function as required. Save the symbol and the 

part in the user created library. It can also be set from the mixed mode simulator but it applies 

only to the current project.  

i. Select Set Parameters | Models (function tool)  Assign Simulation Model 
(option tool). 

ii. Click on the symbol to open a window.  

iii. Click Assign Simulation Function button to assign the simulation function as 

required. 
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Library Browser/ Library Explorer Settings 

 

Path setting for the library files. 
 

The default path for the library files may be set from the options window.  

 

i. Right click System  Options.  
ii. Select Files  Folders.  
iii. Set the path.  

iv. Now to effect this change as the default setting, select the “Save & Exit” from 

the   dropdown button before exiting from this window. 

v. The library path may be set from the menu File/ Change library Path of Library 

Explorer/ Browser but this holds only for the current project.  

Note: If this change is just for the current project, then click the Apply button and exit. 
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